CodeWhale rlm_eval before 0.8.64 Remote Code Execution
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 0.8.41, 0.8.64
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: poc
- Automatable: no
- Technical impact: total
Summary
CodeWhale (packages codewhale / codewhale-tui) versions >= 0.8.41 and < 0.8.64 contain a remote code execution vulnerability in the rlm_eval tool. The tool's approval_requirement() returns ApprovalRequirement::Auto, which the engine treats as 'never prompt,' causing arbitrary model-supplied Python code to run in a python3 interpreter without consulting the user's configured --approval-policy and without any approval prompt or audit step. An attacker can induce the agent to execute arbitrary code via prompt injection in untrusted content the agent reads (a web page, fetched URL, repository file, or MCP tool result); the companion rlm_open tool can stage such content. Code runs on the user's machine at the user's privilege level. Fixed in 0.8.64.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: poc · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- Hmbown CodeWhale
From 0.8.33 · fixed in 0.8.41
- Hmbown CodeWhale
From 0.8.33 · fixed in 0.8.41
- Hmbown CodeWhale
From 0.8.41 · fixed in 0.8.64
- Hmbown CodeWhale
From 0.8.41 · fixed in 0.8.64
- deepseek-tuicrates.io
From 0.8.33 · through 0.8.41
- deepseek-tuinpm
From 0.8.33 · fixed in 0.8.41
- codewhale-tuicrates.io
From 0.8.41 · fixed in 0.8.64
- codewhalenpm
From 0.8.41 · fixed in 0.8.64