Skip to main content
← All vulnerabilities
CVE-2026-75857GHSA-G29H-PFMP-QP9R

CodeWhale before 0.8.64 Privilege Escalation via exec_shell_interact

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 0.8.41, 0.8.64
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: total

Summary

CodeWhale versions >= 0.3.10 and < 0.8.64 (published as deepseek-tui >= 0.3.10 and < 0.8.41 on npm and 0.3.10 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain a vulnerability in the exec_shell_interact (alias exec_interact) tool, whose approval_requirement returns ApprovalRequirement::Auto. This overrides the default Required approval for code-executing tools, so LLM-controlled stdin is written into an already-approved long-running interactive shell (e.g., a python3 -i REPL, mysql, ssh, or sudo -i session) without any approval prompt. An attacker who can inject instructions via untrusted content the agent ingests (a fetched page, MCP result, or repo file) can cause commands to run at the privilege level of that approved process. Fixed in codewhale / codewhale-tui 0.8.64; the deprecated deepseek-tui crate has no fixed release.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Hmbown CodeWhale

    From 0.3.10 · through 0.8.41

  • Hmbown CodeWhale

    From 0.3.10 · fixed in 0.8.41

  • Hmbown CodeWhale

    From 0.8.41 · fixed in 0.8.64

  • deepseek-tuicrates.io

    From 0.3.10 · through 0.8.41

  • deepseek-tuinpm

    From 0.3.10 · fixed in 0.8.41

  • codewhale-tuicrates.io

    From 0.8.41 · fixed in 0.8.64

  • codewhalenpm

    From 0.8.41 · fixed in 0.8.64

References 3

GitHub · Hmbown/CodeWhale

vulncheck.com