Skip to main content
← All vulnerabilities
CVE-2026-75845

ArcadeDB 26.4.2 before 26.8.1 Authorization Bypass via set_server_setting

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 26.8.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: partial

Summary

ArcadeDB versions 26.4.2 through 26.7.3 contain an authorization bypass vulnerability in the set_server_setting MCP server-level tool. SetServerSettingTool.execute() gates only on the global allowAdmin flag and never checks the caller's role, so in an MCP deployment with allowAdmin=true and a non-root allowedUsers set, any authenticated read-only user can invoke set_server_setting to modify server GlobalConfiguration, enabling configuration tampering or denial of service. The issue is fixed in 26.8.1.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • ArcadeData arcadedb

    From 26.4.2 · fixed in 26.8.1

References 2

GitHub · ArcadeData/arcadedb

vulncheck.com