Skip to main content
← All vulnerabilities
CVE-2026-74783GHSA-6Q7J-XR26-3H2C

Scriban 6.6.0 through 7.2.0 Parser Recursion Denial of Service

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 7.2.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: yes
  • Technical impact: partial

Summary

Scriban versions 6.6.0 through 7.2.0 contain a non-enforcing ExpressionDepthLimit guard that fails to stop recursive descent parsing of deeply nested expressions. Attackers can supply templates with deeply nested parentheses, array initializers, object initializers, or unary operators to trigger an uncatchable StackOverflowException that immediately terminates the host process.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • scriban scriban

    From 6.6.0 · through 7.2.0

  • ScribanNuGet

    From 6.6.0 · fixed in 7.2.1

  • Scriban.SignedNuGet

    From 6.6.0 · fixed in 7.2.1

References 2

GitHub · scriban/scriban

vulncheck.com