The expat and elementtree parsers use insufficient entropy for XML hash-flooding protection
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.10.22, 3.11.16, 3.12.14, 3.13.14, 3.14.6, and 1 more
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
`xml.parsers.expat` and `xml.etree.ElementTree` use insufficient entropy for Expat hash-flooding protection, which allows a crafted XML document to trigger hash flooding.\r\n\r\nFully mitigating this vulnerability requires both updating libexpat to 2.8.0 or later and applying this patch.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- Python Software Foundation CPython
fixed in 3.10.22; From 3.11.0 · fixed in 3.11.16; From 3.12.0 · fixed in 3.12.14; From 3.13.0 · fixed in 3.13.14; From 3.14.0 · fixed in 3.14.6; From 3.15.0a1 · fixed in 3.15.0b2
- libpythonBitnami
fixed in 3.10.22; From 3.11.0 · fixed in 3.11.16; From 3.12.0 · fixed in 3.12.14; From 3.13.0 · fixed in 3.13.14; From 3.14.0 · fixed in 3.14.6
- pythonBitnami
fixed in 3.10.22; From 3.11.0 · fixed in 3.11.16; From 3.12.0 · fixed in 3.12.14; From 3.13.0 · fixed in 3.13.14; From 3.14.0 · fixed in 3.14.6
- python-minBitnami
fixed in 3.10.22; From 3.11.0 · fixed in 3.11.16; From 3.12.0 · fixed in 3.12.14; From 3.13.0 · fixed in 3.13.14; From 3.14.0 · fixed in 3.14.6